语义化版本

之前就觉得为什么 github 上的大部分东西都是 1.0.1、1.11.1 甚至 0.11.1 这种奇葩的版本。为什么 jQuery 1.9.9 之后不是 2.0.0 而是 1.10.0。而且在 npm init 的时候不能输入 1 或 1.0 这样的版本,就算你手动修改了 package.json 里的版本之后,就无法安装其他模块,报 Invalid version: "1.0" 无效版本错误。

删除 windows 下 node_modules 过深的目录

说到 node 的模块,确实既好用又蛋疼。相信无数人吐槽 node_modules 目录结构的设计了。
确实,npm 没有处理好 peerDependencies 的概念,不仅重复安装了模块,而且嵌套层次太深。
我觉得可以在安装依然的时候分析相同模块,安装到合适的层次,但是却面临一个相同模块的不同版本问题。
反正确实挺纠结的,我这样的脑子不够用。

brew-cask 之本地更新 node

起因

今天 Node v4.2.2 (LTS) 发布,什么是 LTS 呢,百度之 Long Term Support:长时间支持版本(三年),一般的版本支持为18个月。
所以我打算更新下,其实前几天刚刚折腾了node5后来换回了4.x版本,我这样的小菜暂时先玩玩4.x好了。